Inhalte aufrufen


Profilbild
- - - - -

Probleme mit der .htaccess


  • Please log in to reply
4 Antworten zu diesem Thema

#1 novoo

novoo

    Forumsäule

  • ~Mitglieder
  • PunktPunktPunktPunkt
  • 3.125 Beiträge

Geschrieben: 29 Dezember 2012 - 09:58

Moin Moin,

 

hab meinen Webserverkram bei den Ubernauten und ziehe jetzt mit meinem Blog auf tumblr um. Dort haben ich bereits http://trstn.de als Weiterleitung drin, funktioniert auch soweit.

 

Jetzt will ich auch, dass www.trstn.de auf tumblr weitergeleitet wird. Clever wie ich ja nunmal bin (und Google mir das als erstes Suchergebnis ausspuckte :D) hab ich natürlich einfach ne .htacces mit folgendem Eintrag erstellt:

 

RedirectPermanent / http://trstn.de/

Macht genau das, was es soll. Jetzt kommt aber der Haken an der Sache:

 

Hab ja noch andere Sachen auf dem Server, u.a. sind unter /tumblr noch diverse Images und Bilder für mein tumblr-Theme, welche ja dann natürlich nicht mehr aufzurufen sind, weil ja alles auf tumblr umgeleitet wird.

 

Wie löse ich das am besten? Ich hab so gut wie keine Ahnung von Redirect, htaccess und co.

 

Ich bin mir sicher, das Flo das wieder lösen kann, aber vielleicht weiß ja auch jemand anders von euch mal etwas :D



#2 torhoehn

torhoehn

    Forumsäule

  • ~Mitglieder
  • PunktPunktPunktPunkt
  • 2.378 Beiträge
  • Name: Torben

Geschrieben: 29 Dezember 2012 - 10:15

Probier das hier mal aus:

RewriteEngine On
RewriteCond %{http_host} ^trstn.de [NC]
RewriteRule ^(.*)$ http://trstn.de/$1 [R=301,L]

 

 



#3 novoo

novoo

    Forumsäule

  • ~Mitglieder
  • PunktPunktPunktPunkt
  • 3.125 Beiträge

Geschrieben: 29 Dezember 2012 - 10:20

www.trstn.de leitet dann nicht auf tumblr weiter :/



#4 Pichfl

Pichfl

    Refactoring ftw!

  • Admins
  • 2.832 Beiträge
  • Name: Florian Pichler

Geschrieben: 30 Dezember 2012 - 12:20

Er ist aufm richtigen Weg.

Die Condition sagt: falls der Host mit trstn.de anfängt, leite um. Mein Regex-Fu hat auch schon deutlich nachgelassen weil ich es grade kaum nutze, aber eventuell sollte das hier als alternative Condition helfen:

 

RewriteCond %{http_host} ^(?:www\.)trstn\.de\/ [NC]

 

 

Alternativ gibts natürlich die Möglichkeit einfach alles Umzuleiten, was nicht auf einen echten Ordner zeigt.

<IfModule mod_rewrite.c>
    # Setup (sicherheitshalber)
    Options +FollowSymlinks
    RewriteEngine On
    RewriteBase /

    # remove trailing www (mein boilerplate, sollte funktionieren)
    RewriteCond %{HTTPS} !=on
    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

    # Nur virtuelle Dateien umleiten
    RewriteCond %{REQUEST_FILENAME} !-f # wenn Datei nicht existiert 
    RewriteCond %{REQUEST_FILENAME} !-d # wenn Ordner nicht existiert
    RewriteRule ^(.*) http://trstn.de/$1 [R=301,L]
</IfModule>

 

 

 

Keine Garantie, dass es funktioniert, ich werde das nicht testen. Aber vielleicht schiebt es dich in die richtige Richtung.



#5 novoo

novoo

    Forumsäule

  • ~Mitglieder
  • PunktPunktPunktPunkt
  • 3.125 Beiträge

Geschrieben: 30 Dezember 2012 - 11:35

Vielen Dank. Habs jetzt hinbekommen:

 

RewriteEngine on 
RewriteBase / 
RewriteCond %{REQUEST_URI} !^/blog/
RewriteRule (.*) http://trstn.de/$1 [R=301]

 

Keine Ahnung, ob's richtig oder falsch ist, aber es funktioniert :D






2 Benutzer lesen gerade dieses Thema

0 Mitglieder, 2 Gäste, 0 anonyme Nutzer